Failure of a Chieftec CS-601 USB frontpanel

I own a digital camera which uses SD memory cards. The card used is an “Ultra II SD Plus” card by SanDisk which also incorporates an USB plug – that means you can also use the card without a card reader.

So far this worked without any problems – until the evening of the 4th March 2008. I inserted the card to the front side USB connector and the PC instantly rebootet and there was a smell as if something had been burned. I immediatly turned off the PC and removed the card again.

On the SD card itself I could not find any optical traces of any kind of defects. Also the USB connector looked OK at a first glance and likewise on the mainboard nothing looked charred. After I removed the cables just to be sure I turned on the PC again – everyhing still works.

The ports on the mainboard where also still OK – I connected the USB slot plate (with the PC turned off) to the port which was previously used for the front connectors and the connectors on the slot plate still worked and also provided power. So it seems that only the front connectors where damaged.

In a more closely examination I finally noticed that one of the circuit paths on the board of the case (Chieftec CS-601 with USB/firewire front connectors) has been burned completely – this was the smell coming from:

Burned USB front connector of a Chieftec CS-601
Board of the USB/firewire front connector of a Chieftec CS-601 with „fire damage“
A click on the picture opens a larger version

Leave a Comment

Your email address will not be published. Required fields are marked *